Nowa luka bezpieczeństwa w Adobe Readerze

Który nie bez powodu został uznany za najczęściej atakowany program świata.

Adobe został poinformowany o błędzie przez specjalistę od bezpieczeństwa, Milę Parkour. Błąd jest wykorzystywany przez krążące w sieci specjalnie spreparowane pliki PDF, których nie wykrywają praktycznie żadne programy antywirusowe.

Podatność dotyka Readera 9.3.4 i wszystkich wcześniejszych wersji, na Windowsy, Mac OS Xa oraz Unixy. Żeby było jeszcze ciekawiej, nie ma na razie żadnego sposobu, dzięki któremu użytkownicy mogliby zredukować ryzyko - oczywiście poza unikaniem otwierania dokumentów PDF z nieznanych źródeł.

Według badaczy, złośliwy plik PDF ma wyjątkowo złożoną budowę. Jest skonstruowany tak aby działać na różnych wersjach Adobe Readera, a także mechanizmy pomagające obejść część zabezpieczeń (ASLR czy DEP) wbudowanych w nowsze wersje systemów Windows.

Adobe aktywnie współpracuje z firmami zajmującymi się bezpieczeństwem, aby umożliwić wykrywanie złośliwego kodu przez programy antywirusowe. Nie wiadomo kiedy można będzie spodziewać się łatki, ale biorąc pod uwagę złożoność błędu, będziemy musieli na nią trochę poczekać.

[via The Register]

Maciej Starzycki

Więcej o: